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About This Book

About This Book

This book, the VMware® Workbench Getting Started Guide, provides information about VMware Workbench and
its extensions to the Eclipse IDE.

Revision History
A revision of this book occurs with each release of the product, or as needed. A revised version can contain
minor or major changes. Table 1 lists the revision history of this book.
Table 1. Revision History
Revision

Description

10 September 2015

vSphere 6.0 U1 GA – Workbench 3.5.3 GA

12 March 2015

vSphere 6.0 GA – Workbench 3.5.1 GA

29 Sept 2014

vSphere 6.0 RC – Workbench 3.5 GA

30 June 2014

vSphere 6.0 Beta 2 – Workbench 3.5 Beta

Intended Audience
This book is for VMware customers partners who develop and certify products using VMware Workbench.

VMware Technical Publications Glossary
VMware Technical Publications provides a glossary of terms that might be unfamiliar to you. For definitions
of terms as they are used in VMware technical documentation, go to http://www.vmware.com/support/pubs.

Documentation Resources
Each Workbench plug‐in contains its own help documentation that displays in the Help > Help Contents
window. PDF copies of these documents may be available on the VMware Developer Center Web site.

Documentation Feedback
Please send feedback to this documentation through your VMware partners representative.
VMware also welcomes your suggestions for improving our other VMware API and SDK documentation.
Send your feedback to: docfeedback@vmware.com.

Technical Support and Education Resources
For all questions relating specifically to the VMware Workbench, see the VMware partner co‐dev web site:
http://www.vmware.com/partners/alliances/programs/co‐dev/iovp.htm

VMware, Inc.
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The following sections describe VMware technical support and educational resources available to you.

Online Support and Telephone Support
To use online support to submit technical support requests, view your product and contract information, and
register your products, go to http://www.vmware.com/support.

Support Offerings
To find out how VMware support offerings can help meet your business needs, go to:
http://www.vmware.com/support/services

VMware Professional Services
VMware Education Services courses offer extensive hands‐on labs, case study examples, and course materials
designed to be used as on‐the‐job reference tools. Courses are available onsite, in the classroom, and live
online. For onsite pilot programs and implementation best practices, VMware Consulting Services provides
offerings to help you assess, plan, build, and manage your virtual environment. To access information about
education classes, certification programs, and consulting services, go to http://www.vmware.com/services.
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Introducing VMware Workbench IS

1

VMware Workbench IS is VMware developed plug‐in to the Eclipse Integrated Development Environment
(IDE), and can assist development of applications for VMware vSphere and vCloud. The user interface retains
the look and feel of Eclipse, but with VMware‐specific extensions. Additional plug‐ins are available to support
specific products and technologies.

Installing VMware Workbench
The following sections cover prerequisites and how to install VMware Workbench IS in Eclipse.

Operating System Support
On a 64‐bit Windows machine, you should install 64‐bit Eclipse. Both Eclipse and VMware Workbench will
then require a 64‐bit Java Development Kit.
On Linux, if you installed Eclipse using root (superuser) permissions, you must install VMware Workbench
using root permissions as well.

Hardware Requirements
As of Workbench 3.5, the default memory for the machine running Eclipse is 3GB. To accommodate this
default and maintain satisfactory performance, the physical machine that provides the Eclipse infrastructure
for Workbench should meet the following requirements:


Dual core processor



4GB RAM



40GB of free HDD space

Download and Install VMware Workbench
In the VMware Developer Center, find the introduction page for VMware Workbench IS. At the bottom of page
is a button to Download the VMware Workbench IS plug‐in as a ZIP file.
The plug‐in installs (add software) to any recent version of Eclipse.
To install the VMware Workbench plug-in
1

In Eclipse, click Help > Install new Software.

2

Click the Add button on the right, then click Archive.

3

Browse to the UpdateSite-WBIS-com.vmware.vide* file that you downloaded from Developer Center.

4

Click the top level VMware Workbench Integrated Suite check box to select and install all features.

5

Click through the wizard, accepting the EULA. Restart Eclipse to apply the changes.

VMware, Inc.
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Configuring VMware Workbench
To install additional plug‐ins, you might need to set HTTP and HTTPS proxies in Eclipse if your physical or
virtual machine is behind a firewall, and does not already have proxies set.

Setting Network Proxies
The first time you start Eclipse with VMware Workbench, you can set proxies for HTTP and HTTPS as well as
proxy by‐passes for local machines that you will connect to.
At first start up, a dialog displays that encourages you to configure proxy settings.
In subsequent start ups, you can reach proxy settings by clicking Window > Preferences. Expand the General
preferences and click Network Connections.
To set HTTP proxies
1

Select Manual proxy configuration in the Active Provider drop‐down menu.

2

Highlight HTTP and click Edit.
Verify the proxy server name and port number are correct, or type the correct proxy and port number.

3

Select HTTPS and click Edit.
Verify the proxy server name and port number are correct, or type the correct proxy and port number.
CAUTION Do not edit the SOCKS (socket secure) proxy and authentication. Doing so may cause
errors. Leave it unset.

4

In the Proxy bypass list, add systems on your intranet that you want Eclipse to find.
The following example shows various types of entries you might want to add:
10.*
*.example.com
127.0.0.1
localhost

Wildcards can be used for IP addresses and domain names. Domain names can have only three parts.
5

Click Apply to save changes, and click OK.
You are now ready to install development kits and certification tests.

Accessing Help Resources
Kit‐specific, Workbench‐specific and general Eclipse help topics are available from the Help menu by selecting
Help Contents. The Help browser displays a list of available help libraries. You can search all topics or narrow
the scope using the search tool. Tabs at the bottom of the left pane allow you to view the following items:


Table of contents for any document



Consolidated index of all topics



Search results



Bookmarks you have set in the help topics

Installing Additional Plug-ins
You can install additional software plug‐ins for your development kit or certification tests from the update site.
See “Install New Software Instructions” on page 18.
After installing a software plug‐in, you must restart VMware Workbench. While in the Install Software wizard,
after you have installed all of the software packages you need, click Restart Now. See “Installing New VMware
Workbench Software Packages” on page 18.
8
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Navigating the Workbench UI with the Dashboard
To start working with the VMware Workbench UI, use the Dashboard. This feature is the first screen presented
to you upon logging in for the first time. You can access this page from anywhere in the VMware Workbench
UI by selecting VMware > Dashboard from the menu bar.
From the Dashboard, the following information and actions are available:


Information and instructions for common Getting Started tasks and problems



View VMware partner news items



View a list of the plug‐ins already installed



Download and install certification plug‐ins



Check for Global Certification Waivers



Download and install development kits (SDKs)



Download and install current debug symbols



Preview documentation before installing a plug‐in

For instructions on how to use the Dashboard, see “The VMware Workbench Dashboard” on page 11.

VMware, Inc.
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The VMware Workbench Dashboard

2

The VMware Workbench Dashboard contains active links to assist your development kit and certification suite
workflow. The Dashboard appears when you initially start VMware Workbench. Some links on the Dashboard
are inactive or hidden until you sign in. If you dismiss the Dashboard, you can return to it later by selecting
VMware > Dashboard from the menu bar.
This chapter covers the following Dashboard topics:


“Signing In to See Content” on page 11



“Workbench Panel” on page 12



“Certifications Panel” on page 12



“Development Panel” on page 15

Signing In to See Content
Locate and click the blue Sign In button on upper right. Usually your sign‐in ID is your company email
address. You can choose whether to use your My VMware or Partner Central password. Some items are
viewable only with Partner Central credentials.
After you sign in, your email address appears to the left of the Sign In button, and you can access content for
all links on the left. Navigation bread crumbs will appear near the top, starting with Home.

Login Troubleshooting
If you fail to log in successfully, you will see one of the following error messages:
The account or password entered was incorrect.
Failed to connect through Dashboard.

Try the following remedies to fix the problem:


Make sure you have configured network proxies correctly. See “Setting Network Proxies” on page 12 of
this document.



Make sure that the virtual appliance is connected to the network. For instance, verify that the Connected
check box on the VM > Settings > Network Adapter page is selected.



Verify that your VMware Workbench can access VMware Developer Center Repository by opening the
web browser view (Window > Show View > Other > General > Internal Web Browser) and type the
following URL for the VMware Developer Center Repository:
https://vdc-repo.vmware.com/api

You should see the date and time on the vdc‐repo server. If this does not appear, ask your IT department
to verify that you have access to the VMware Developer Center Repository site.

VMware, Inc.
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Workbench Panel
The top section on the left side provides information about VMware Workbench.

Getting Started
This line is selected initially, with helpful information displayed to the right. If you select another line, new
information replaces the getting started instructions summarized below.


First‐time user? – Instructions for configuring the network proxy.



Common issues and troubleshooting – Suggestions for solving common issues.



Still have questions? – An email contact for getting questions answered.

News
VMware partner news and announcements about Workbench. Clicking a link opens a browser panel inside
Workbench and displays the news or announcement.

Installed Packages
A list showing the VMware Test Manager and any certification suites or development kits already installed.
Clicking a link leads you to start the Test Manager or to start a project for your development kit.

Certifications Panel
The middle section on the left side provides information about VMware certifications.

Certifications
Click the Certifications link to see a list of the certification kits available to you. If a message appears saying
“you must log in to access available Certifications” then sign in with your company email address and either
your My VMware or Partner Central password.


After the list of Certifications appears, you can click on any certification kit that you are interested in.
The Package Details pane appears with information about the certification, including a short description,
links to install or download the package, a link to documentation, platform type, vSphere version,
package version, and dependencies.


You can preview the manual for a certification kit before you install the package, by clicking the link
to view on‐line documentation.



You can download a package to a local file system for installation on a machine not connected to the
Internet. Specify the download location. The file name is prefilled for you. For complete installation
instructions, see “Installing Software Packages” on page 17.



You can install a package to the machine you are working on. The installation wizard starts when
you click to install the package. Update Site (Work with) is automatically filled in for you, saving you
from having to cut and paste the Update Site from another location.
NOTE During install the Contact all update sites during install to find required software check box
is selected to pick up any dependent packages. Non‐VMware update sites are disabled to avoid
changing Workbench by installing incompatible software. If you want to install extra software, you
must do it before installing any plug‐ins. Click Window > Preferences > VMware > Dashboard and
uncheck Disable non‐VMware Update Sites when installing VMware plug‐ins.
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From the Package Details pane, you can navigate back to any previous page by clicking breadcrumbs, or
click Certifications to see the list of available packages again.
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Global Certification Waivers
If the computer you are using for certifications is not connected to the Web, not even through a proxy, see
“Global Waivers for Non‐Internet Connected Computers” on page 13.

Global Waivers for Internet Connected Computers
If the computer you are using for certifications is connected to the Web, click the Global Certification Waivers
link to see a list of Product Types for which waivers are available.
Click Download to obtain the current list of Global Waivers. The global certification waivers list gets
downloaded to /opt/vmware/waivers/waivers.xml by default, and soon an expandable list appears in the
Global Certification Waivers > Product Types pane. You can refresh this list by downloading again.
In the Global Certification Waivers > Product Types pane, waivers are categorized: IO Devices, SRA (storage
replication adapter), (ESXi) Server, Storage Array, VASA, and possibly others. Click one of the types to view
the Waiver Details for that type.
The Waiver Details pane contains a list of the waiver IDs and a description of each. Clicking the waiver ID
displays all available information about that waiver, including a short description, a detailed summary of the
waiver, the list of waived tests, and the list of waived releases.
Some of the Product Type categories have a large number of waivers related to them. You can use the search
box to restrict the list of waivers based on a keyword.
Figure 2-1. Searching waiver details

You can apply waivers to the tests you are running, or after tests have run, in the Test Manager by clicking the
gearbox button (
) then clicking Apply Waivers from the pop‐up menu. Select the waivers you want to
apply from the list and click OK. Only the waivers that apply to the certification will be applied.

Global Waivers for Non-Internet Connected Computers
If your certification computer is not connected to the Web, follow this procedure to install the waivers:
1

Install VMware Workbench Toolsuite on a computer that is connected to the Internet.
You can retrieve the Workbench Toolsuite from the VMware Developer Center:
https://developercenter.vmware.com/group/workbench/toolsuite/3.5

2

Start Workbench Toolsuite and log in with your credentials.

3

On the Workbench Dashboard, under Certifications, click the Global Certification Waivers link to see a
list of Product Types for which waivers are available. (The list of product types appears only if you have
already downloaded the list of certification waivers.) Click Download to obtain the list of Global Waivers.

4

Specify a place on your hard drive for the waivers.xml file, for example C:\temp.
Click OK and the waivers.xml file will be downloaded to the location you specified.

5

Copy the file to portable media and take the media to the non‐Internet connected computer where your
certification setup is run. On your certification computer where the VMware Workbench virtual appliance
is installed, copy the waivers.xml file to the /opt/vmware/waivers/ directory.

6

Start Workbench and open the certification session.

7

You can apply waivers to the tests you are running, or after tests have run, in the Test Manager by clicking
the gearbox button (
) then clicking Apply Waivers from the pop‐up menu. Select the waivers you
want to apply from the list and click OK. Only the waivers that apply to the certification will be applied

Certification Submission and Status
To upload certification submission bundles, check the status of your submission, and view SR incident status,
click the Certification Details and Submission Status link.
VMware, Inc.
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Figure 2-2. Managing your certification submission

Manually Upload a Saved Submission Bundle
If you saved a submission bundle that you want to upload, click the top link Click here to manually upload
a saved certification submission bundle. In the resulting Upload Certification Submission Bundle dialog,
browse to locate your *.zip or *.gzip certification submission bundle, click Upload, and click Finish.
The resulting submissions upload properties will become visible in the Project Explorer view. If not already
created, a new folder called manual_uploads will be created that contains Submission.prop and *.zip or
*.gzip files in folders labeled by submission date, as shown in Figure 2‐3.
Figure 2-3. Project Explorer Submission.prop file

Click the Submission.prop file to open it in an editor for viewing. Further submission status can be accessed
in the Dashboard, as shown in Figure 2‐4.

Available SR Incidents
To see all of the SR (service request) incident reports that you have filed, click the second link Click here to list
available SR incidents. The resulting Certification Details and Submission Status pane contains your account
information, a summary of SR incidents, and details of your SR incident reports.

Submission Status
All your current certification sessions are listed. To refresh the list, click the Refresh icon. To view the
Certification Submission and Status details page, click Click here.

Certification Submission Status
To check status of your certification submission, click the third link Click here for more certification and
submission status details. The resulting Certification Submission Status pane contains a list of your cert
submissions with Cert Name, Cert Type, Transaction Id, Submission Status, and Cert Detail.

14
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If you wish to export the submission status of your certifications in comma‐separated variable (CSV) format,
click the Export link. A dialog allows you to name the .csv file and choose where to store it.
If your certification submission status looks out of date, click the Refresh link and icon to update the status of
your certification sessions.
Figure 2-4. Certification Submission and Status Detail Page

Once your submission has started the VMware review process, a clickable link appears under Cert Details.
The Cert Details page contains product and certification details and lists compatible or equivalent products.

Add Transaction Ids
This section list submission status of certifications by a given transaction ID. If you know the transaction ID of
a certification that was submitted on a different instance of VMware Workbench, you can add it by clicking
Add status by Transaction Id, and keying in the ID. All columns, except the certification name, are populated
with information about that transaction ID. You can delete the entry for an added transaction ID by clicking
the X icon next to the entry.

VCG Preview
If you would like to see a preview of how your certifications will look in the VMware Compatibility Guide
(VCG), you must have signed in using your VMware partner credentials. The page lists the ESXi versions you
have certifications for, and product types for each version. Click the appropriate product type to see how your
certifications will be listed in the VCG. If you find any errors in the entry for your product(s), notify VMware
to have it corrected.

Development Panel
The Development section appears at bottom left of the Dashboard. You might need to scroll down to see it.

SDKs
Click the SDKs link to see a list of development kits available to you. If a message appears saying “you must
log in to access available SDKs” then sign in with your company email address and either your My VMware
or Partner Central password. After sign in, you can do the following tasks at this link:


VMware, Inc.
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Click the link for an available development kit to see Package Details.
The Package Details pane provides information about a development kit, including short description,
links to install or download the package, a link to documentation, platform, programming language,
vSphere version, and dependencies.


You can preview the manual for a development kit before you install the package, by clicking the link
to view on‐line documentation.



You can download a package to a local file system for installation on a machine not connected to the
Internet. Specify the download location. The file name is prefilled for you. For complete installation
instructions, see “Installing Software Packages” on page 17.



You can install a package to the machine you are working on. The installation wizard starts when
you click to install the package. Update Site is automatically filled in for you, saving you from having
to cut and paste the Update Site from another location.
NOTE During install the Contact all update sites during install to find required software check box
is selected to pick up any dependent packages. Non‐VMware update sites are disabled to avoid
changing Workbench by installing incompatible software. If you want to install extra software, you
must do it before installing any plug‐ins. Click Window > Preferences > VMware > Dashboard and
uncheck Disable non‐VMware Update Sites when installing VMware plug‐ins.



From the Package Details pane, you can navigate back to any previous page by clicking breadcrumbs, or
click SDKs to see the list of available packages again.

Debug Symbols for VMkernel Updates
If you have not already done so, sign in to access the Debug Symbols repository. For debugging, you will need
to update Workbench’s debug symbols to match the version of ESXi host that is being tested.
To see a list of the available debug symbol files, click the Debug Symbols for VMkernel Updates link. To
download a debug symbol file, click the link(s) of the build number(s) matching the ESXi build number for
your host(s) under test, optionally change the save folder, and click OK.

16
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You can install software packages (plug‐ins) from inside an Internet‐connected Workbench virtual appliance,
or download them to portable media (sneaker‐net) and install them on a Workbench virtual appliance that is
not connected to the Internet. One way to download development kits and certification suites is to use the
Dashboard. Another way is Eclipse’s Install New Software feature to download and install plug‐ins.
This chapter contains the following topics:


“Simplified Installation Instructions from the Dashboard” on page 17



“Install New Software Instructions” on page 18



“Installing Packages Offline (Sneaker‐Net)” on page 20



“Fixing Proxy Issues” on page 21



“Uninstalling Software” on page 21

Simplified Installation Instructions from the Dashboard
The easiest way to install a software package in Workbench is from the Dashboard because the URL for the
various SDKs and certifications is already filled in. The Dashboard is the first screen presented to you when
Workbench starts up. However, you can always get to the Dashboard by navigating to VMware > Dashboard.
To install a software package from the Dashboard:
1

You must sign in to see the list of available SDKs or certifications. See “Signing In to See Content” on
page 11.

2

On the left side, click either the SDK or Certifications link to see the list of SDKs or certifications that you
can download and install.

3

Click the name of the SDK or certification that you wish to install.

4

Click the link to install the SDK or certification package to the local machine. The installation wizard starts
after you click here to install. Update Site (Work with) is automatically filled in for you, saving you from
having to cut and paste the Update Site from another location.

5

In the Install wizard, click Select All, and then click Next.

6

On the Install Details page, click Next.

7

Review the license, select I accept the terms of the license agreement, and click Finish.

8

During the install, a dialog box appears telling you the module is unsigned. Click OK.

9

At the end of the installation, a dialog box asks you for permission to restart VMware Workbench. If you
are done installing software packages, click Yes. If you have more to install, click No.

VMware, Inc.
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Install New Software Instructions
You can install software using the classic Eclipse method where you provide the URL for a software package.
This allows you to specify arbitrary software packages for a custom approach.

Specifying Available Software Sites
There may be multiple software sites from which you must download packages. Sometimes a package on one
site has a dependency on a package on another download site. VMware Workbench can coordinate this for
you and automatically download the components you need to satisfy any dependencies. To set up this feature,
use the Available Software Sites preferences.
Set up Available Software Sites preferences
1

From the VMware Workbench click Help > Install New Software and click the Install link for the plug‐in.

2

From the Install dialog box, click Available Software Sites.
The Preferences dialog box displays with Install/Update expanded and Available Software Sites
selected.

3

Click Add to display the Add Repository dialog box.

4

Determine the URL you need from your partner site on the Developer Center or from another source.
Enter, or copy and paste, the URL of the download site in the Location text box.

5

Type a name for that update site location in the Name text box. Click OK.
The update site appears, added to the list of available software sites in the Preferences dialog box.

6

The status of the site should be Enabled. If the status of the site is Disabled, select the site and click Enable.

7

Repeat the Add operation until you have added and enabled all the available software sites that you will
be using for VMware Workbench.

8

When you are finished, click OK to dismiss the Preferences dialog box and return to the Install dialog box,
where you can proceed to installing new software packages.

Installing New VMware Workbench Software Packages
You can add VMware Workbench software packages and certification tests or update existing packages using
the Install dialog. You can reach the Install dialog two ways: by clicking Help > Install New Software, or by
clicking Install in the Dashboard Development panel under SDKs, after you have logged in.
Software packages can be installed from a site you already entered using the Available Software Sites dialog,
from a network update site, or from a local folder (after downloading the ZIP files to a local folder).
IMPORTANT Before you install any software packages, proxy settings must be configured. Failure to configure
proxy settings can result in the installation stalling. You were offered the opportunity to set proxies when you
installed the base VMware Workbench appliance. If you have not already configured the proxy settings, see
“Fixing Proxy Issues” on page 21.
Install software packages from the list of available software sites
1

From the Install wizard, make a selection from the Work with drop‐down menu.

2

Click Select All, or select the check box next to the package name, and click Next.
The system calculates the requirements and dependencies for the package(s) you selected.
NOTE The Contact all update sites during install to find required software check box is not selected by
default here in the Install wizard, unlike when installing plug‐ins from the Dashboard. Additionally,
non‐VMware Update Sites are disabled here as they are when installing from the Dashboard.

18
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(Optional) You can expand VMware Workbench <Package Name> in the Name column to see the list of
components included in the package. You can choose to exclude some or all components by deselecting
them, however this step is not necessary because the installation software prevents you from installing
duplicate or unnecessary components.
3

Review the Install Details, and click Next.

4

Review the license text, select I accept the terms of the license agreements. You cannot install the
software without agreeing to the license terms. Click Finish. The software installation can take several
minutes to complete. If you are asked to accept unsigned content, click OK.

5

When installation is complete, a dialog box advises you to restart Eclipse for the changes to take effect and
asks you if you want to restart now.
If you have other packages to install, click No.
If you are finished installing software packages, click Yes to restart Eclipse.

Install software packages from the network update site
1

Open a Web browser and go to the VMware download site for your development kit or certification suite.

2

Copy the URL for the software package to download.

3

Click Help > Install New Software. From the Install dialog box, click Add.

4

The first time you install the package, paste the URL into the Location text box. Type a Name. Click OK.
VMware Workbench <Package Name> shows in the text box.
If you are reinstalling the package (for an update of the software), select the update site from the list in the
Work with drop‐down menu.

5

Select the check box next to the package name, and click Next.
The system calculates the requirements and dependencies for the packages you have selected.
(Optional) You can expand VMware Workbench <Package Name> in the Name column to see the list of
components included in the package. You can choose to exclude some or all components by deselecting
them, however this step is not necessary because the installation software prevents you from installing
duplicate or unnecessary components.

6

Review the Install Details and click Next.

7

Review the license text, select I accept the terms of the license agreements. You cannot install the
software without agreeing to the license terms. Click Finish. The software installation can take several
minutes to complete. If you are asked to accept unsigned content, click OK.

8

When installation is complete, a dialog box advises you to restart Eclipse for the changes to take effect and
asks you if you want to restart now.
If you have other packages to install, click No.
If you are finished installing software packages, click Yes to restart Eclipse.

Install software packages from a local folder
1

In the Dashboard, you can choose to download a package to a local folder. Alternately, you can open a
browser in the Workbench virtual appliance and go to a VMware download site. Download the ZIP file
containing a software package. For example, download the following file:
UpdateSite-<package name>-com.vmware.vide-<version number>.zip

2

Make a new directory and move the ZIP file into it, for example /home/vmware/update.

3

In VMware Workbench, click Help > Install New Software.

4

Click Add to open the Add Repository dialog box.

5

Click Local, navigate to the update file path (repository root directory) and click OK.

6

Back in the Add Repository dialog box, type a name for the package and click OK.
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7

Click Select All, or select the check box next to the package name, and click Next.
The system calculates the requirements and dependencies for the package(s) you selected.
(Optional) You can expand VMware Workbench <Package Name> in the Name column to see the list of
components included in the package. You can choose to exclude some or all components by deselecting
them, however this step is not necessary because the installation software prevents you from installing
duplicate or unnecessary components.

8

Review the Install Details, and click Next.

9

Review the license text, select I accept the terms of the license agreements. You cannot install the
software without agreeing to the license terms. Click Finish. The software installation can take several
minutes to complete. If you are asked to accept unsigned content, click OK.

10

When installation is complete, a dialog box advises you to restart Eclipse for the changes to take effect and
asks you if you want to restart now.
If you have other packages to install, click No.
If you are finished installing software packages, click Yes to restart Eclipse.

Installing Packages Offline (Sneaker-Net)
To accommodate those who do not have Internet access for installation of the software packages, VMware
Workbench installation packages can be downloaded and transferred (sneaker‐net) as individual ZIP files. You
can download software packages from the same site where the base VMware Workbench package resides.
Install software packages off-line
1

On a machine connected to the Internet, using the Dashboard of the Workbench virtual appliance or
Workbench IS, click the “download” link for one of the SDKs or Certifications. Download the software
package as a ZIP file. Copy it to portable media. For example, download and copy the following file:
UpdateSite-<package name>-com.vmware.vide-<version number>.zip

2

Insert the portable media into the system running the Workbench virtual appliance where you wish to
install the package.

3

On the Workbench virtual appliance, make a new directory, for example /home/vmware/update, and
copy the ZIP file from portable media into the update directory.

4

In VMware Workbench, click Help > Install New Software.

5

Click Add to open the Add Repository dialog box.

6

Click Local, navigate to the update file path (repository root directory) and click OK.

7

Back in the Add Repository dialog box, type a name for the package and click OK.

8

Click Select All, or select the check box next to the package name, and click Next.
The system calculates the requirements and dependencies for the package(s) you selected.
(Optional) You can expand VMware Workbench <Package Name> in the Name column to see the list of
components included in the package. You can choose to exclude some or all components by deselecting
them, however this step is not necessary because the installation software prevents you from installing
duplicate or unnecessary components.

9

Review the Install Details, and click Next. Review the license text, select I accept the terms of the license
agreements. You cannot install software without agreeing to the license terms. Click Finish. Installation
can take several minutes to complete. If you are asked to accept unsigned content, click OK.

10

When installation is complete, a dialog box advises you to restart Eclipse for the changes to take effect and
asks you if you want to restart now.
If you have other packages to install, click No.
If you are finished installing software packages, click Yes to restart Eclipse.
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Fixing Proxy Issues
If you have problems with the installation seeming to stall or taking a long time to complete, or you cannot
open a terminal, you might need to configure proxy settings.
Fix proxy issues
1

In VMware Workbench (Eclipse) menu bar, click Window > Preferences.

2

On the left side, expand General and click Network Connections.

3

In the Active Provider drop‐down menu, select Manual proxy configuration.

4

Verify that you have the HTTP and HTTPS proxies set properly. If not, select them one at a time, click Edit,
and type the correct settings for the proxy host and port.
a

Verify the proxy server name and port number are correct.

b

In the Proxy bypass list, add the list of IP addresses or host names for which the proxy server should
not be used. Use of wildcards is permitted. The list might look something like this:
*.example.com
127.0.0.1
localhost

5

Click Apply to save changes.

6

Click OK to exit.

Uninstalling Software
Also see the Eclipse Workbench User Guide for detailed instructions about removing software packages that are
already installed.
CAUTION Even though it is possible to remove software packages, VMware advises against it. If you must do
it, VMware urges you to be extremely careful because you risk rendering other packages inoperable because
of missing dependencies. Data loss is possible.
Many installed packages contain common modules that are needed by other installed software packages
(development kits and certification suites). If you inadvertently remove a common module that other installed
software depends on, you can render those software packages inoperable.
If you have used the software to create valuable data that you want to keep, take measures to copy the files to
a safe location before uninstalling the software.
Uninstall software
1

In the VMware Workbench (Eclipse) menu bar, click Help > About VMware Workbench.

2

Click Installation Details to see the Installation Details page.

3

On the Installed Software tab, select the package to uninstall, and click Uninstall.
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Using the Remote System Explorer

4

The Remote System Explorer (RSE) is an Eclipse plug‐in for connecting to and performing operations on
remote systems. VMware has extended the standard RSE tool to connect to remote servers. This chapter
contains the following sections:


“RSE Functions” on page 23



“Configuring SSH on Your Target Machine” on page 23



“Accessing the RSE” on page 24



“Connecting to Windows Machines and Virtual Centers” on page 24



“Connecting to an ESXi Server” on page 24



“Properties and Details For ESXi Servers” on page 25



“Launching SSH Terminals” on page 29



“Configuring SSH Services on an ESXi Host” on page 29



“Managing Packages on an ESXi Host” on page 30



“Monitoring Server Logs” on page 31



“Installing VIB Packages on the Remote System” on page 31



“Managing Passwords” on page 31

RSE Functions
You can use the ESXi connections that you create in RSE to do the following functions:


Transfer files between your local system and a remote system.



Run commands on the remote system.



Install and deploy VIB packages on the remote system



Test your module before certification



Run certification tests

Configuring SSH on Your Target Machine
To ensure that SSH is configured properly to work with RSE, do the following:
1

Make sure that SSH is enabled on the target machine.
SSH is not enabled by default on a hardened SLES11 SP3 VM.
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a

In a terminal window on the target machine, log in as root.

b

Start SSH.
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service sshd start

2

For hardened SSH servers, change or add configure parameters.
Default values for a hardened SSH server (sshd) may be different than on other non hardened servers.
Change the SSH configuration file to contain the following configuration parameters.
a

Change to the location for the configuration file. The Linux configuration file is located at:
/etc/ssh/sshd_config

b

Add or change to the following values:
MaxSessions 20
AllowTcpForwarding yes

Accessing the RSE
When you open the Project Explorer by selecting Develop Your ESXi <Module Type>, in the development kit
menu, VMware Workbench also opens the RSE.
To explicitly open the RSE in VMware Workbench, perform one of the following:


Select Window > Open Perspective >Remote System Explorer.



Select Window > Show View > Remote Systems.

Connecting to Windows Machines and Virtual Centers
In the RSE New Connection wizard, you can choose to make remote connections to Windows machines and
Window Virtual Centers. The process is essentially the same as with ESXi servers as explained in sections of
this document that follow, but you must use Windows login credentials.
IMPORTANT For Windows Server 2008, the Datastore daemon is not installed by default. You must install it
on your Windows system and have it running before the RSE can connect to it successfully.

Connecting to an ESXi Server
You need to connect to ESXi servers for testing and debugging purposes. Use the RSE to add server
connections to your VMware Workbench session. If you have not already added the ESXi machine to your list
of remote hosts, add it now. If you already have the ESXi machine added to the RSE, you must connect to it
before you can install modules.

Add an ESXi Server
1

Display the New Connection dialog box.
With the RSE open in the VMware Workbench, right‐click inside the Remote Systems pane and select
New > Connection from the menu. (If it is the first time you’ve opened the RSE, and nothing is already
selected, the right‐click menu will have only two selections: New Connection and Import Connections.

2

Select ESX from the list of system types and click Next.
You can filter your choices by typing ESX in the System type text box before selecting ESX in the list.

3

If the Parent profile drop‐down menu has more than one choice, select the profile to use.

4

Supply the host name or IP address in the Host Name text box, or choose one of the ESXi hosts in the
drop‐down menu (if present).
If you are creating a new connection to a host that is not in the drop‐down menu, the Next button becomes
available. (Click Next to view the messages.)

5
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(Optional) Type in a name in the Connection name text box, if you want it to be different than the host
name.
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6

(Optional) Type in a description of the ESXi host in the Description text box.

7

Select or deselect the Verify host name check box.
The check box is selected by default. When selected, it checks to see if the host name is a valid name.

8

(Optional) Type in a User Name and Password in the text boxes.
The root user name is the default. You can manage user names and passwords in the Preferences dialog
box. See “Managing Passwords” on page 31 for instructions on setting and changing passwords.

9

Select or deselect the Save password check box.
The check box is selected by default.

10

Click Finish.

Start the SSH daemon on your remote system
1

In the Remote System Explorer, right‐click the target ESXi machine, and select VMware > Configure SSH
Service from the menu.

2

In the SSH configuration dialog box, observe the Status.

3

(Optional) If the Status is Stopped, click Start in the Service Commands area and click OK.

Connect to an ESXi server
Once you have added an ESXi machine, you must connect to it. With the remote ESXi host highlighted in the
RSE pane, select Connect from right‐click menu.
NOTE If the connection fails with “failed to connect sshd to <the ESXi host>”, the SSH process must be started.

Disconnect from an ESXi Server
If you wish to break the connection to one of the ESXi machines, select the ESXi host in the RSE pane and select
Disconnect from the right‐click menu.

Properties and Details For ESXi Servers
After you have connected to an ESXi server, the Remote Systems navigation tree contains many items of
information about the server. The following sections describe each of the items available for ESXi servers.

Remote Systems Navigation Tree
The Remote Systems navigation tree contains the following items for a connection to an ESXi server.
Table 4-1. Remote Systems Navigation Tree Items
Navigation Tree Item

Description

File Explorer

Expand this item to view the local file system on the remote server.

Ssh Terminals

Click this item to create a SSH terminal window to the remote server. See
“Launching SSH Terminals” on page 29 for more information.

Resource Explorer

List of resources that you can add to the ESXi machine.
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Remote Systems Properties
The Properties tab displays information about the currently selected remote system (or Local).
Table 4-2. Properties for the Items in the Remote Systems Navigation Tree
Property

Description

Connection status

Connection status of subsystems.

Default User ID

User ID specified when the connection to the remote system
was established.

Description

Description of this connection.

Host name

Host name or IP address of the remote system.

Name

Name of resource.

Number of children

Number of children currently under this parent.

Parent profile

Profile that owns this connection.

Remote system type

Type of remote host, for example, ESX.

Type

Type of resource, such as Connection.

Remote Systems Details
The Remote Systems Details tab displays the status of the connections in the Remote System Explorer. This tab
provides you with an overview of the properties and other information of all connected remote systems. The
columns in this tab correspond to the properties listed in Properties tab for the currently selected remote
system.
Table 4-3. Remote Systems Details Tab Items
Column

Description

Resource

Name of the remote system connection.

Parent Profile

Parent profile specified when the remote system connection was
established.

Remote system

Type of remote host, for example, ESX.

Connection status

Connection status of subsystems.

Host Name

Name or IP address of the remote host.

Default User ID

User ID specified when the connection to the remote system was
established.

Description

Description of this connection.

Resource Explorer
The Resource Explorer displays resources and their properties for each ESXi connection in the Remote Systems
tab.

Resource Types
The following resource types are listed under every remote system: Virtual Machines, SCSI LUNs, Storage
Adapters, Data Stores, Virtual Switches, Network Adapters. Each resource type can be expanded to show the
list of actual resources found on this ESXi machine.
When you click a resource type, a list of properties and their values show in the Properties tab. If the Properties
tab is not displayed on the UI, you can access the properties by selecting the resource type and selecting
Properties from the right‐click menu.
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The Resource Explorer itself has the following properties:
Table 4-4. Resource Explorer Properties
Property

Value

Connected

Yes/No – Answering the question, “Currently connected to this service?”

Name

Name of resources, for example, Resource Explorer.

Number of children

Number of entries under this resource type.

Port

Port to use when connecting to this remote subsystem.

Type

Subsystem: Resource Explorer

User ID

User ID for connecting to this service, for example, root (Inherited)

Version

Version, release and modification of remote system, if available.

Every resource type has the following properties:
Table 4-5. Resource Type Properties
Property

Value

Connection‐private

Yes/No – Answers the question, “Is this a connection‐private filter pool, which only
exists for this connection?”

Name

Name of resource type, for example, Virtual Machines.

Number of children

Number of resources currently under this resource type.

Number of filter
strings

Number of filter strings that are contained in this filter.

Parent filter

Filter containing this filter. Not applicable for resource types.

Parent filter pool

Filter pool that directly or indirectly contains this filter.

Type

The type of resource, for example, Remote system filter.

Resources
When you click one of the resources listed under the resource type, a list of properties and values for that
resource displays in the Properties tab. The following is a list of resource types and their properties:


Virtual machines
The Properties tab shows the following properties for each virtual machine on the ESXi host:
Table 4-6. Virtual Machines Properties
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Property

Value

File

VMX file location.

Full Name

Full resource name in system.

Guest OS

Name of guest operating system as it is identified in the system, for example,
otherLinuxGuest.

HostName

Full host name, for example, host1.server1.example.com. Available only while the
host is running.

IP Address

Available only while the host is running.

Memory

Amount of memory this virtual machine has, in MB.

numCPU

Number of CPUs this virtual machine has.

Power

Status of virtual machine, either poweredOn, poweredOff, or suspended.

Tools Status

VMware tools status.

SCSI LUNs
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The Properties tab shows the following properties for each SCSI LUN:
Table 4-7. SCSI LUNs Properties



Property

Value

Device ID

Identifier for the device, for example, mdx.vrrhoa2:C0:T0:L0.

Device Type

Generic term for device type, for example, disk.

Model

Vendor’s model number for this device, for example, ST373207LW.

Vendor

Name of vendor, for example, SEAGATE.

Storage adapters
The Properties tab shows the following properties for each storage adapter:
Table 4-8. Storage Adapters Properties



Property

Value

Driver

Driver name, for example pata_amd.

Model

Model name, for example, AMD 8111 IDE/PATA Controller

PCI

PCI identifier, for example, 00:07.1

Status

Status information, if available.

Datastores
The Properties tab shows the following properties for each datastore:
Table 4-9. Data Stores Properties



Property

Value

Capacity

Amount of space in Gigabytes.

Free Size

Amount of free space in Gigabytes.

Location

Path for this volume, for example,
/vmfs/volumes/49b07ab9-2921257e-d158-0030485da766.

Type

Type of file system, for example, VMFS.

VMs

List of running virtual machines that use this datastore.

Virtual switches
The Properties tab shows the following properties for each virtual switch:
Table 4-10. Virtual Switch Properties
Property

Value

Free Num Ports

Number of available ports on this virtual switch.

MTU

Size in bytes of the largest data unit that the switch can pass onwards.

NumPorts

Number of total ports.

Uplinks

List of vNIC (network adapter) names the virtual switch uplinks to.

In addition, each virtual switch can have multiple port groups assigned to it. Each port group has
properties of its own:
Table 4-11. Port Group Properties
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Property

Value

Uplinks

List of uplinks for this port group, for example, [vmnic0].
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Table 4-11. Port Group Properties (Continued)



Property

Value

Used Ports

Number of assigned ports in the port group.

VLAN ID

The VLAN ID for this port group. Value if no VLAN ID is assigned: 0.

Network adapters
The Properties tab shows the following properties for each network adapter:
Table 4-12. Network Adapter Properties
Property

Value

Driver

The name of the driver, for example, tg3.

Duplex

Duplex mode, for example, FULL, HALF.

MAC

Unique hardware identifier (MAC Address), for example, 00:30:48:5d:a7:66.

PCI

PCI identifier, for example, 02:05.0.

Speed

Link speed in Megabytes per second, for example, 100 Mbps.

To refresh a node in the Resource Explorer
1

Select a node in the Resource Explorer.

2

Select Refresh in the right‐click menu.

To clear a bad password in the Resource Explorer
If you entered a bad password, select Clear Password in the right‐click menu. Upon next access, the user name
and password dialog box displays.

Launching SSH Terminals
With SSH enabled, you can launch an SSH terminal by selecting Ssh Terminals and selecting Launch Terminal
from the right‐click menu.
A Terminal tab opens with a command line available for your use for that ESXi connection.
If you added an ESXi host but you can’t open a terminal, it might be a proxy issue. Check your proxy settings.
See “Fixing Proxy Issues” on page 21.

Configuring SSH Services on an ESXi Host
To configure SSH services on an ESXi host, select VMware > Configure SSH Service from the right‐click menu
in the Remote Systems pane. The SSH configuration page displays.
Choose a startup policy
1

Select one of the startup policies: Start automatically, Start and stop with host (the default), Start and
stop manually.

2

Click OK to exit.

Start, stop or restart SSH
1

Click one of the Service Commands buttons: Start, Stop, Restart.
The action is taken on the host immediately. You see the Status change.

2
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Managing Packages on an ESXi Host
You can add or remove VIBs, VIBs in an offline bundle, or image profiles to or from an ESXi host using the RSE
Package Manager. To access the Package Manager, highlight the ESXi host in the Remote Explorer pane and
select VMware > Package Manager from the right‐click menu.
The Package Manager displays with a list of the packages installed on the host.
Add a package
1

Click Add to display the Install Wizard.

2

Select the package to install: a VIB package from a local file or URL, a VIB package from a depot or offline
bundle, or an image profile from a depot or offline bundle and click Next.

3

Supply the location of the VIB, offline bundle or image profile.
a

For VIBs: In the VIB Location page, specify the local file or URL for the VIB package to install. Click
Browse to find it in the local file system, or click Projects to find it in the Project Explorer.

b

For VIBs in an offline bundle: In the Depot Location page, enter a depot URL or offline bundle ZIP
file from a server. Click Browse to find it in the local file system.
The VIB packages available in that depot or offline bundle display.

c

For an image profile: In the Depot Location page, enter a depot URL or off‐line bundle ZIP file from
a server. Click Browse to find it in the local file system.
The image profiles available in that depot or offline bundle display.

4

Click Next to display the Install Options page.

5

Select the options for installation and click Next.

6

Click Install to start installation.
If there are errors, they will display in the text box.

7

When the installation completes, click Finish.
The Packages installed on host <host name> list displays with the new package listed.

Remove a package
1

Highlight one or more packages and click Remove.
The Uninstall Wizard displays with a list of the VIB packages to be removed.

2

Select the Uninstall Options and click Next.

3

Click Uninstall.
If there are any errors, they will display in the text box.

4
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Monitoring Server Logs
Depending on which version of ESXi you have installed, a different set of logs is available for monitoring:
Table 4-13. ESX/ESXi Logs by Version
ESX/ESXi Version

Logs

ESXi 5.0, 5.1and 5.5

/var/log/vmkernel.log
/var/log/hostd.log
/var/log/vpxa.log

ESXi 4.1

/var/log/vmkernel.log
/var/log/hostd.log
/var/log/vmware/vpx/vpxa.log
/var/log/messages

ESX 4.0 and 4.1
Classic

/var/log/vmkernel
/var/log/vmware/hostd.log
/var/log/vmware/vpx/vpxa.log
/var/log/messages
/var/log/vmksummary
/var/log/vmkwarning

Monitor a server log
1

In the RSE, highlight an ESXi host.

2

Select VMware > Monitor System Logs from the right‐click menu.
A view opens for the ESXi host logs. A default log displays.

3

To select a different log, use the drop‐down menu.
The log displays. Use the scroll controls to move back and forward through the log.

Installing VIB Packages on the Remote System
Before installing a VIB on the remote ESX, make sure that sshd is started on the remote ESX. See “Start the SSH
daemon on your remote system” on page 25.
Install package on remote system
1

To install files on a remote ESXi system, select the system host name in the Remote Systems pane.

2

Right‐click in the pane, and choose VMware > Install Package from the right‐click menu.
A dialog box displays where you specify the name of the VIB to deploy and the ESXi host to deploy it on.
For instructions on installing a VIB, see “Installing Your Test VIB on a Test ESXi Host” on page 92.

Managing Passwords
To set or change user names and passwords, use the Eclipse Preferences dialog box.
To manage user names and passwords
1

Select Preferences from the Window menu.

2

In the left navigation frame in the Preferences window, expand the Remote Systems menu and select
Passwords.

3

To add a user to any ESXi in the list, click Add.
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In the New Saved Password dialog box, complete the following fields:

4

a

Type in the host name.

b

Select ESX from the System type drop‐down menu.

c

Type a User ID.

d

Type in a password for the new user and verify it by retyping it.

e

Click OK.

To change a saved password, select a host from the host name list and click Change.
In the Change Saved Password dialog box, type the new password and verify it by retyping it. Click OK.

5

To delete a user name and password, select the entry in the list of existing host names and their user IDs,
and click Remove.
NOTE No confirmation is required before the entry is deleted. Use with caution.
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Using the Workbench Log Browser

5

The Log Browser in the Workbench UI supports the viewing and analysis of vSphere and Workbench log files.
This chapter presents the following topics:


“Loading Log Files into Workbench” on page 33



“Tour of the Workbench Log Browser” on page 34



“Recording a Log Browser Session” on page 35



“Displaying and Using the Activity Graph” on page 35



“More About the Log Browser UI” on page 37

Log Browser features are also available in the vSphere Web Client, however they operate faster in Eclipse or
VMware Workbench, and you can choose to display an activity graph.

Loading Log Files into Workbench
The Workbench Log Browser works by creating .logx files in a designated folder. Rather than open log files
directly, Log Browser is driven by these .logx configuration files, which tell Eclipse where to find a set of logs
on local disk, or how to import a set of log files across the network. The .logx files also describe how to parse
the log files into columns for display in a table.
Prerequisite To fetch logs from a remote system, if you have a network proxy set, you first must add the
system’s hostname or IP address to the Proxy bypass list in Window > Preferences > Network Connections.
When you open (or double click) a .logx file in the Project Explorer pane, a tabular display with controls
appears in the same pane where the Dashboard appeared. You can then filter, highlight, and examine the log.
To start using the Log Browser
1

In VMware Workbench, click File > New > Log Analysis.
Or to analyze logs associated with a project, select the project and right click New > Log Analysis.

2

To the right of the Source host drop‐down list, click Add.

3

In the Select Remote System Type dialog, click ESX for an ESXi host, Virtual Center for vCenter Server,
or another choice. You will probably be asked for a password.

4

Back in the Log Host and Format Selection dialog, choose a Log Format. You can either Browse to an
existing Project container, or type in the name of a new folder to be created.
For vCenter Server Appliance, you will need to know the parent directory where your log files reside. For
example, the vpxd logs appear in the /var/log/vmware/vpx directory.
For an ESXi host, you can select Standard Log Collection and get most of the available log types.

5
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To analyze Log Browser entries
1

With a log that scrolls past the end of pane, type a search term in the text box on upper left and click Filter.
To make the filter more precise you can enable Case sensitive.

2

To restore all lines in the log, click Unfilter.

3

You can display context around a matching filter term, and show one (1) or more adjacent lines in the log,
by changing 0 in the drop‐down list between Filter and Case sensitive. The lines of context appear with
alternating green and white backgrounds.

4

Instead of or in addition to filtering, you can emphasize a term by typing in the text box on upper right
and clicking Highlight. The term appears in yellow.

5

There are two tabs at the bottom of the pane, one saying Log Viewer, the other giving the .logx file name.
If you click the second, it shows the XML definition for retrieving and formatting this log type.

Tour of the Workbench Log Browser
Once you have a set of .logx files in a project, and open one of them, you can browse logs using directives in
the vLogBrowser menu or Eclipse toolbar.

Opening an Existing Log Project
You can open an existing log analysis file that you saved to the Project Explorer by expanding the project name
and double‐clicking the .logx file. The file opens in a Workbench Log Browser view.

Enhanced Search with Named Filters
In addition to simple keyword filtering, you can perform more complex filtering using the Named Filter
facility. With a Log Viewer pane displayed, find the Eclipse menu and click vLogBrowser > Filter. The toolbar
contains the same icon as a shortcut.
A dialog box appears, Keyword Filtering with a Named Filter. By default the Filter Source is the current .logx
file, but you can also open other .logx files, or take filters from a file on disk.
You can create a new named filter by adding keyword or regular expressions and using And/Or/Not boolean
operators, then clicking Save. Later you can use the Named Filters drop‐down list to choose that saved filter
by name. You have a drop‐down box to include 1 or more adjacent lines. When ready, click Save and Filter.
Only filters from this .logx file can be applied to the log. Filters from other sources can be viewed, but must
be saved to this .logx file before you can edit or apply them.

Copying Log Entries to Clipboard
To search for log entries that match a search string, find the Eclipse menu and click vLogBrowser > Find. The
toolbar contains the same icon as a shortcut.
In the Find by keyword dialog box, you can click either Find All or Find next. In either case, click Close then
vLogBrowser > Copy to copy all these log entries to your desktop Clipboard.

Finding and Synchronizing Time Stamps
To see a log entry created near a certain time, in the Eclipse menu click vLogBrowser > Find or Adjust Date.
The toolbar contains the same icon as a shortcut. In the Find by Timestamp or Adjust All Timestamps dialog,
use the date and time picker to select a month and date, optionally change time, and click Find.
If you want to synchronize time stamps between logs, click the Sync button in both .logx browser windows,
and the matching log entries that are nearest your specified time will be highlighted in both windows.
The Sync button also works without the dialog box. If you highlight a log entry in one .logx browser window
a nearby timestamp will be highlighted in other .logx browser windows with Sync button checked.
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You can also adjust time stamps, for instance to correct clock skew. This adjustment does not affect the actual
log entires, only the display in the .logx browser window. To adjust time stamps, specify a date and time and
click Find. In the box underneath Time, specify the date and time to adjust and click Adjust. The adjusted
appearance appears in red, and the time difference (as an offset minus or plus) appears beneath. To undo the
time adjustment, click Clear Adjustment.

Refreshing a Log
To reload the log entries in a .logx file, click vLogBrowser > Refresh. The toolbar contains the same icon as a
shortcut. The lower right corner of Eclipse shows a progress bar for the refresh.
To view information about a loaded or refreshed .logx file, click vLogBrowser > View Log Info. The toolbar
contains the same icon as a shortcut. The Log File Information dialog shows the source host, the full path and
filename, the time stamp, and the file size in bytes. Log files are listed in chronological order.
If there is a log file on the local system that you want to add to the list, click vLogBrowser > Add Log Files and
browse to the location of the local log file.
Click vLogBrowser > Export to export the current .logx file, in a variety of formats (XML, text, JSON, CSV)
to a local file, in your Eclipse workspace by default. You can export all events, or a subset of filtered events.

Cheat Sheets
Eclipse offers Cheat Sheets to introduce certain features.
NOTE You can view cheat sheets for Workbench Log Browser by clicking Help > Cheat Sheets then expanding
VMware vLogBrowser to select the desired cheat sheet.
VMware implemented three cheat sheets to explain Log Browser. Two of those cheat sheet topics are not
covered in this chapter: importing a remote log file into the local project, and opening a local log file.

Recording a Log Browser Session
You can create a recording of some or all the actions that you take in the log browser. The recording is stored
as a shell script (lb-script.sh) that can be replayed from the command line, edited, or embedded in another
shell script. For more information about the command‐line, see Appendix A, “Log Browser Command Line,”
on page 101.
Start and stop recording
1

Start the recording of log browser actions by clicking the red start recording icon.

2

In the Select a file to save generated script contents pop‐up window, either accept the default name
(lb.‐script.sh) and location (inside your project folder), or choose your own name and location, and click
OK.
If you are attempting to overwrite an existing script with the same name and location, a warning pops up.
Click OK to continue overwriting an old script, or click Cancel to rename or relocate the script.
The icon changes to the stop recording icon.

3

After you perform the log browser actions you want to record, click the stop recording icon:

Displaying and Using the Activity Graph
The log browser includes an activity graph view that can show activity from multiple log files over a period
of time. Activity graphs can be useful to identify irregular activity, such as a system reboot or a peripheral that
stops responding.
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Open the Activity Graph
1

From the Window menu, click Show View > Other.

2

From the Show View dialog box, expand VMware.

3

Click Activity Graph and click OK.
Figure 1. Activity Graph displaying three logs

Display log files in the activity graph
1

Click the plus (“+”) icon at top right of the activity graph to open the Add Log File(s) to Graph dialog box.

2

Select one or more log files that you want to display. Click OK.
The dialog box displays the log files already open in Workbench Log Browser. Each log is represented by
a separate time line with the time scale spread out on the horizontal axis.
You can enlarge the activity graph window by clicking the Maximize button on upper right, and return
to original size by clicking the Restore button (same location, different name and shape).

3

Adjust the time scale on the horizontal axis in one of three ways:
a

In one of the time lines, click and drag the cursor across an area of the time line that you are interested
in expanding. When you release the cursor, the area you highlighted is expanded to fill the entire time
line. The time scale is adjusted on the bottom axis.

b

Select one of the Zoom chart links at the top of the activity graph: 1min, 1hour, 1day, 1week, 1month.
The time line at the bottom changes to display the activity during that time interval.
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c

Click the Zoom In or Zoom Out (magnifying glass) buttons to uniformly expand the time scale or
shrink the time scale.
There are upper and lower bounds to the zoom scale. You will receive a warning message if you
Zoom In to less than 100 ms, or Zoom Out to more than 10 years.

4

Use the Zoom Back and Zoom Forward (yellow arrow) buttons at the top of the activity graph to move
backward and forward through previous zoom settings.

5

To scroll through the entire log, move the Scroll chart horizontal slider at the top left of the activity graph
to move the view left or right.
IMPORTANT Double‐clicking on an individual line in the activity graph causes the corresponding entry
in the log browser to be highlighted.

More About the Log Browser UI
The vLogBrowser pane displays formatted log entries. Each log entry is formatted into columns. For
VMkernel logs, the column headers are: #, Date, CPU, World ID, and Entry. For hostd and other logs the
column headers are: #, Date, Source and Entry (log text).
In the log browser, you can perform the following tasks:


Double‐clicking an entry causes a dialog box to open, displaying other text associated with the log entry.
Click OK when you are ready to dismiss the dialog box.



Filter for specific keywords by typing the keyword into the unlabeled text box on the top left of the
Workbench Log Browser view and clicking Filter. The button is a toggle. If you wish to return to the
unfiltered view of the log, click Unfilter.



Before clicking Filter, if you want to see the log entries immediately surrounding the entry with the
keyword, select the number of surrounding entries to display from the numerical drop‐down menu.



Sort the log entries by any column by clicking the column header once to sort in ascending order and click
again to sort in descending order. Restore the original order by clicking the number (“#”) column header
to get ascending order.



Synchronize log entries in multiple log browsers by a specific timestamp. Select the Sync check box in
each log browser that you want synchronized. Select a time stamped entry in one of the browsers. The
other log browsers have the log entry closest to that timestamp selected.



Click the <log_file_name.logx> tab at the bottom of the vLogBrowser pane to see the .logx configuration
file (XML formatted).
You can customize this log view by editing the XML in the .logx file. To see the changes, save, close and
reload the file.



Various actions are available in the right‐click menu, from the task bar icons, or from the vLogBrowser
menu in the VMware Workbench menu bar:
a

Filter – The Keyword Filtering with a Named Filter dialog box displays.
In the Choose a Filter Source area, select one of the radio buttons: This .logx file, Filters file (and
Browse for the file), or Other open .logx files (select the file from a drop‐down list).
To create your own named filter, type a name in the Named Filters field or select an already existing
named filter from the drop‐down menu. Edit or accept the keywords for the filter in the regular
expression formatting fields that follow. If you want to include lines surrounding the filtered lines,
choose the number to include in the Include # Surrounding Lines selector.
To save your new named filter or edited filter, click Save.
To delete the filter in the Named Filters field, click Delete Filter. To clear the regular expressions form,
click Clear Form.

VMware, Inc.

37

VMware Workbench IS Guide

To save the new or edited Named Filter and filter the .logx file, click Save and Filter. To unfilter the
.logx file and clear the regular expression form, click Unfilter and Clear Form.
b

Find – The Find by keyword dialog box displays. Enter the keyword to search for in the Keyword
text box. Click Find All to see all entries in the log browser containing the keyword selected. Click
Hide to close the dialog box. Click Find next to find the next instance of the keyword in the log
browser.

c

Find Next – When selected, takes you to the next entry containing the keyword you searched for
previously. If you haven’t selected keyword, it opens the Find by keyword dialog box.

d

Find or Adjust Date– The Find by Timestamp or Adjust All Timestamps dialog box displays.
To find a specific timestamp, type the desired timestamp in the Date Input field and click Find to go
to the first entry in the log with that timestamp.
Or you can construct the timestamp using the calendar and clock controls in the dialog box. Changes
you make using the calendar controls are reflected in the timestamp shown in the Date Input field.
For example, changing the month to February changes the timestamp month to 02. For the time
portion of the timestamp, highlight a section of the clock display and click the buttons on the right to
increment or decrement the number. For example, highlight the hour, and click the bottom button to
decrement the hour number.
To adjust all of the timestamps in the log, set the desired timestamp in the Date Input field, and click
Adjust. You can revert to the original timestamp by clicking Clear Adjustment.

e

Highlight – The Highlight a keyword dialog box displays. Type in the keyword to highlight and
click Highlight. All instances of the keyword in the log are highlighted. Click Unhighlight to turn off
the highlighting. Click Hide to close the dialog box.
To highlight keywords using the Highlight button on the Workbench Log Browser interface, type in
a keyword in the unlabeled text box on the right side of the Workbench Log Browser view and click
Highlight. The button is a toggle. If you wish to remove highlighting of the keyword, click
Unhighlight.
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f

Copy – Copy the selected entry or entries to the clipboard. You can open a text editor and paste the
entries into a document.

g

Refresh – If additional log entries have been added to the log since you started analyzing it, you can
select Refresh from the menu to bring those additional entries into the view. This works for logs on
the local file system as well as logs from the ESXi hosts you are connected to.

h

View Log Info – A pop‐up window displays the list of logs and their locations that you currently
have loaded in this Workbench Log Browser project.

i

Add Log Files – Add local logs files to an existing Workbench Log Browser project (.logx file). The
Add local log files to table dialog box displays. Browse to the log directory and select one or more
logs to add. Click Add to add the files to the .logx file. The log display refreshes to include the new
entries.
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